Issue affecting Net2phone call processing
Incident Report for net2phone
Resolved
This incident has been resolved.
Posted Jun 03, 2023 - 12:06 EDT
Investigating
Net2phone is aware that some customers are having issues with call processing. Our engineering and support teams are all engaged and working on resolving this issue as we speak; further updates to follow.
Posted Jun 03, 2023 - 11:24 EDT