Issue affecting Net2phone call processing
Incident Report for net2phone
Resolved
This incident has been resolved.
Posted Aug 26, 2024 - 16:39 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Aug 26, 2024 - 16:24 EDT
Investigating
Net2phone is aware that some of our customers are experiencing issues with call completion. Our engineering and support teams are actively engaged on this issue and working to resolve and quickly as possible.
Posted Aug 26, 2024 - 14:57 EDT
This incident affected: net2phone Unite (net2phone Call Processing).