Issue Affecting Net2Phone web dialer

Incident Report for net2phone

Resolved

The incident has been resolved
Posted May 13, 2024 - 10:24 EDT

Update

The issue has been identified and a fix is being implemented.
Posted May 13, 2024 - 10:04 EDT

Identified

The issue has been identified and fix is being implemented
Posted May 13, 2024 - 10:01 EDT

Update

We are continuing to investigate this issue.
Posted May 13, 2024 - 09:52 EDT

Investigating

Net2Phone is aware of an issue affecting web dialer. Be aware that our support team is actively engaged and working on the issue.
Posted May 13, 2024 - 09:49 EDT
This incident affected: net2phone Unite (net2phone Web Portal).