Voice Quality Degradation
Incident Report for net2phone
Resolved
This incident has been resolved.
Posted Sep 15, 2023 - 17:18 EDT
Monitoring
A fix has been implemented and call quality is back to normal.
Posted Sep 15, 2023 - 17:07 EDT
Identified
Some customers may experience a degraded voice quality. The issue has been identified and our team is working on a fix.
Posted Sep 15, 2023 - 16:36 EDT
This incident affected: net2phone Unite (net2phone Call Processing).