Issue Affecting Net2Phone Login

Incident Report for net2phone

Resolved

The issue has been resolved.
Posted Jul 16, 2026 - 07:21 EDT

Monitoring

Net2Phone has implemented a workaround and it is currently being monitored.
Posted Jul 16, 2026 - 07:14 EDT

Investigating

Net2Phone is aware of intermittent issues with Net2Phone Portal and Huddle access. Our team is actively investigating and working to restore service as quickly as possible.
Posted Jul 16, 2026 - 05:03 EDT
This incident affected: net2phone Unite (net2phone Web Portal).