Issue affecting Net2phone uContact

Incident Report for net2phone

Resolved

This incident has been resolved.
Posted Feb 17, 2025 - 18:29 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 17, 2025 - 18:24 EST

Update

We are continuing to work on a fix for this issue.
Posted Feb 17, 2025 - 18:24 EST

Identified

The issue has been identified and a fix is being implemented.
Posted Feb 17, 2025 - 18:20 EST

Investigating

Net2phone is aware that some customers are having issues with uContact. Our engineering and support teams are engaged and working on resolving the issue.
Posted Feb 17, 2025 - 18:15 EST