Issue Affecting Net2Phone Call Processing
Incident Report for net2phone
Resolved
The issue is resolved, calls are completing normally.
Posted Mar 29, 2023 - 11:48 EDT
Investigating
Net2phone is aware that some customer are having issues with PDD and completing calls - Our engineering and support teams are all engaged and working on resolving this issue as we speak; further updates to follow.
Posted Mar 29, 2023 - 11:23 EDT
This incident affected: net2phone Unite (net2phone Call Processing).