Issue Affecting Net2Phone Messenger
Incident Report for net2phone
Resolved
This incident has been resolved.
Posted Mar 03, 2023 - 16:46 EST
Identified
Net2Phone is aware of an issue affecting Unite Messenger. Be aware that our support team is actively engaged and working on the issue.
Posted Mar 03, 2023 - 16:36 EST
This incident affected: net2phone Unite (net2phone Messenger).